Using jQuery migrate for more compatible jQuery plugin

I bet in your Front-end development, you have experienced when maintaining a project that have many jQuery plugins. I faced the similar one: my PM told me that there’re some functions that don’t work. After doing ‘Google’, I got that the current version of jQuery made this issue. After updating to the latest version of jQuery, it worked well. Unluckily, the other functions failed. This reason made this s**t was also incompatible version of jQuery. WTF?

Fortunately, I found one more solution with jQuery migrate (https://github.com/jquery/jquery-migrate/). I embedded this plugin and the bugs before went away. 😀

Leave a Reply